Apex Customer Portal Apex Customer Portal
Forums Pictures Articles Downloads
Advanced purchasing for Electrical, Plumbing, and HVAC contractors
Register Active Topics Members Search Bookmarks FAQ
Save Password Forgot your password?
 All Forums
 Running Apex on a Terminal Server
 Printer Friendly Version  
Author Previous Topic Topic Next Topic  

131 Posts
Posted - January 31 2005 :  11:08:26 PM  Show Profile Send a private message to admin
How do you configure a terminal server for Apex?

Edit 7/29/2014: If you are installing Apex 10.8 or above you do not need to worry about these installation options. Simply install Apex from the installation CD (or network share).

Answer: Apex will run great on a terminal server, but you have to be careful about security issues. Apex users will need to be able to write to some directories, files, and registry entries that by default will be protected on a terminal server. Allowing Apex to write to these areas will not compromise your terminal server's security.

  1. Ensure all users have full access to the BDE directory (i.e. give the "Everyone" group "Full Control"). By default the BDE directory is at c:\program files\common files\borland shared\bde.

  2. With Apex 10 and above you can skip this step. In the BDE Administrator select the ApexCS database alias and set the Schema Cache to FALSE. At the end of this procedure you should ensure that it is still FALSE when you log in as a non-admin user.

  3. Ensure that all users have full read/write access to the [HKEY_LOCAL_MACHINE\SOFTWARE\Borland\Database Engine] registry key on 32-bit operating systems, or [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Note\Borland\Database Engine] on 64-bit operating systems. (Once again, give "Everyone" "Full Control".)

  4. In general, it is a good idea to change the System Environment variable for the Temp and Tmp variables to %USERPROFILE%\Local Settings\Temp. This isn't essential, though, unless you are still unable to run Apex after following the other steps.

  5. If the SQL Server (or MSDE) program is also running on the Terminal Server, run CliConfg.exe. From the General tab, make sure that "Enable shared memory protocol" is disabled (unchecked). Also, remove TCP/IP from the Enabled protocols, leaving only Named Pipes. Note that running SQL Server on a Terminal Server is very resource intensive and is not recommended by Microsoft.

Jump To:

Set as your default homepage Add favorite Privacy   2017 Vulcan Software LLC All Rights Reserved.   Go To Top Of Page